On Friday 05 April 2013 06:49 PM, Felipe Balbi wrote: > On Fri, Apr 05, 2013 at 06:29:00PM +0530, Santosh Shilimkar wrote: >> OMAP5 and future OMAP based SOCs has backward compatible MPUSS >> IP block with OMAP4. It's programming model is mostly similar. > > s/It's/Its/ > s/mostly // > > (similar already expands to 'almost the same' :-) > >> @@ -355,6 +389,12 @@ int __init omap4_mpuss_init(void) >> >> save_l2x0_context(); >> >> + if (cpu_is_omap44xx()) { >> + omap_pm_ops.finish_suspend = omap4_finish_suspend; >> + omap_pm_ops.resume = omap4_cpu_resume; >> + omap_pm_ops.scu_prepare = scu_pwrst_prepare; >> + } > > why don't you just rename omap4_* into omap_* and add cpu-based checks > there in order to handle differences between omap4 and omap5? > The whole idea is to handle all these SOC specific stuff in init and not sprinkle the checks in runtime code. > If implementation will be almost the same for both, you might be able to > save on some more duplication, no ? > The implementation is not same and hence. If it was same, I wouldn't have introduced function pointers :) Regards, Santosh -- To unsubscribe from this list: send the line "unsubscribe linux-omap" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html