On 09/26/2012 07:41 PM, Dmitry Torokhov wrote: > On Wednesday, September 26, 2012 09:57:57 AM Joe Perches wrote: >> On Wed, 2012-09-26 at 20:31 +0530, Kishon Vijay Abraham I wrote: >>> The PHY framework provides a set of API's for the PHY drivers to >>> create/destroy a PHY and API's >> >> Just some trivial notes. >> >>> diff --git a/drivers/phy/phy-core.c b/drivers/phy/phy-core.c >> >> [] >> >>> @@ -0,0 +1,445 @@ >> >> [] >> >>> +static void devm_phy_release(struct device *dev, void *res) >>> +{ >>> + struct phy *phy = *(struct phy **)res; >> >> That's a bit twisted isn't it? >> Perhaps >> struct phy *phy = res; > > No, because you really need to dereference ptr, not simply cast. To avoid this confusion I suggest to create a struct phy_res. For now its only member will be a pointer to a struct phy. > > ... > >>> + >>> + ptr = devres_alloc(devm_phy_release, sizeof(*ptr), GFP_KERNEL); >> >> Is this the right size? >> >> Because ptr is **, perhaps sizeof(struct phy) is clearer. > > But incorrect. A proper struct will make the code more readable here, too. Marc -- Pengutronix e.K. | Marc Kleine-Budde | Industrial Linux Solutions | Phone: +49-231-2826-924 | Vertretung West/Dortmund | Fax: +49-5121-206917-5555 | Amtsgericht Hildesheim, HRA 2686 | http://www.pengutronix.de |
Attachment:
signature.asc
Description: OpenPGP digital signature