Rafael, 2011/7/31 Rafael J. Wysocki <rjw@xxxxxxx>: > On Thursday, July 28, 2011, jean.pihet@xxxxxxxxxxxxxx wrote: ... >> @@ -113,6 +109,8 @@ void device_pm_remove(struct device *dev) >> { >> pr_debug("PM: Removing info for %s:%s\n", >> dev->bus ? dev->bus->name : "No Bus", dev_name(dev)); >> + /* Call PM QoS to de-init the per-device latency constraints */ >> + pm_qos_dev_constraints_deinit(dev); > > I'd call this function "dev_pm_qos_constraints_destroy()" (and the previous > one "dev_pm_qos_constraints_init()" for consistency). Ok ... >> +/* Called from the device PM subsystem at device init */ >> +void pm_qos_dev_constraints_init(struct device *dev) >> +{ >> + plist_head_init(&dev->power.latency_constraints.list, &dev->power.lock); >> + dev->power.latency_constraints.target_value = >> + PM_QOS_DEV_LAT_DEFAULT_VALUE; >> + dev->power.latency_constraints.default_value = >> + PM_QOS_DEV_LAT_DEFAULT_VALUE; >> + dev->power.latency_constraints.type = PM_QOS_MIN; >> + dev->power.latency_constraints_init = 1; > > You could avoid adding this field if there were a PM_QOS_UNINITIALIZED > (or PM_QOS_UNKNOWN) type. > > And if you _really_ want to have a separate field, why don't you put it > into latency_constraints ? Ok I remove latency_constraints_init and use the type field instead. ... > > Thanks, > Rafael Thanks, Jean -- To unsubscribe from this list: send the line "unsubscribe linux-omap" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html