Hi, > -----Original Message----- > From: ext Keshava Munegowda [mailto:keshava_mgowda@xxxxxx] > Sent: 28. maaliskuuta 2011 10:19 > To: Jokiniemi Kalle (Nokia-MS/Tampere); linux-usb@xxxxxxxxxxxxxxx; linux- > omap@xxxxxxxxxxxxxxx; Felipe Balbi > Cc: Krogerus Heikki (Nokia-MS/Helsinki); jhnikula@xxxxxxxxx; Kevin Hilman > Subject: RE: [PATCH v2 2/2] RX-51: Enable isp1704 power on/off > > > + > > static struct platform_device rx51_charger_device = { > > - .name = "isp1704_charger", > > + .name = "isp1704_charger", > > Both are same; you don't need this change! No, actually they are not same. I added tab instead of space to match indentation with the .dev member. This is the correct way IMHO. - Kalle > > > > > + .dev = { > > + .platform_data = &rx51_charger_data, > > + }, > > }; > > > > +static void __init rx51_charger_init(void) > > +{ > > + BUG_ON(gpio_request_one(RX51_USB_TRANSCEIVER_RST_GPIO, > > + GPIOF_OUT_INIT_LOW, "isp1704_reset")); > > + > > + platform_device_register(&rx51_charger_device); > > +} > > + > > #if defined(CONFIG_KEYBOARD_GPIO) || > defined(CONFIG_KEYBOARD_GPIO_MODULE) > > > > #define RX51_GPIO_CAMERA_LENS_COVER 110 > > @@ -928,6 +951,6 @@ void __init rx51_peripherals_init(void) > > if (partition) > > omap2_hsmmc_init(mmc); > > > > - platform_device_register(&rx51_charger_device); > > + rx51_charger_init(); > > } > > > > -- > > 1.7.1 > > > > -- > > To unsubscribe from this list: send the line "unsubscribe linux-omap" in > > the body of a message to majordomo@xxxxxxxxxxxxxxx > > More majordomo info at http://vger.kernel.org/majordomo-info.html -- To unsubscribe from this list: send the line "unsubscribe linux-omap" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html