Re: [PATCH]omap hsmmc: fix incorrect capability reporting

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Nishanth Menon <nm@xxxxxx> wrote:
> S, Venkatraman had written, on 03/30/2010 01:11 PM, the following:
> [..]
>>>>
>>>> diff --git a/drivers/mmc/host/omap_hsmmc.c
>>>> b/drivers/mmc/host/omap_hsmmc.c
>>>> index 83f0aff..dbf83a6 100644
>>>> --- a/drivers/mmc/host/omap_hsmmc.c
>>>> +++ b/drivers/mmc/host/omap_hsmmc.c
>>>> @@ -2093,7 +2093,7 @@ static int __init omap_hsmmc_probe(struct
>>>> platform_device *pdev)
>>>>
>>>>      if (mmc_slot(host).wires >= 8)
>>>>              mmc->caps |= MMC_CAP_8_BIT_DATA;
>>>> -     else if (mmc_slot(host).wires >= 4)
>>>> +     if (mmc_slot(host).wires >= 4)
>>>>              mmc->caps |= MMC_CAP_4_BIT_DATA;
>>>>
>>> Since 8-bit is the max how about:
>>>
>>>       if (mmc_slot(host).wires == 8)
>>>               mmc->caps |= MMC_CAP_8_BIT_DATA | MMC_CAP_4_BIT_DATA;
>>>       if (mmc_slot(host).wires == 4)
>>>               mmc->caps |= MMC_CAP_4_BIT_DATA;
>>>
>>> This would be little easy to read the code.
>>
>> Sure. Works for me.
>
> nitpicky comment: might be better off using a switch(mmc_slot(host).wires)
> statement instead of using == if that is the intention here..

Too verbose for just 2 cases, with the 'case's and 'default's adding
nothing to readability. YMMV.

Thanks,
Venkat.
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [Linux Arm (vger)]     [ARM Kernel]     [ARM MSM]     [Linux Tegra]     [Linux WPAN Networking]     [Linux Wireless Networking]     [Maemo Users]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite Trails]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux