Re: [PATCH 3/8] omap: zoom2: split baord file for reuse

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 




Pandita, Vikram had written, on 11/03/2009 03:20 PM, the following:
Please fix subject typo:
[PATCH 3/8] omap: zoom2: split baord file for reuse
				^^^^
				board
[...]
diff --git a/arch/arm/mach-omap2/board-zoom-peripherals.c b/arch/arm/mach-omap2/board-zoom-peripherals.c
new file mode 100755
index 0000000..c799eca
--- /dev/null
+++ b/arch/arm/mach-omap2/board-zoom-peripherals.c
generic -> zoom Vs LDP.. Vs Zoom2 Vs Zoom3 naming conventions.. are we saying we dont care about LDP anymore? all zooms are zoom2 or zoom3?

[...]
+
+//static struct twl4030_gpio_platform_data zoom_gpio_data = {
+//     .gpio_base              = OMAP_MAX_GPIO_LINES,
+//     .irq_base               = TWL4030_GPIO_IRQ_BASE,
+//     .irq_end                = TWL4030_GPIO_IRQ_END,
+//     .pulldowns              = BIT(0) | BIT(1) | BIT(2) | BIT(3)
+//                             | BIT(4) | BIT(5)
+//                             | BIT(8) | BIT(9) | BIT(10) | BIT(11)
+//                             | BIT(12) | BIT(13) | BIT(14) | BIT(15)
+//                             | BIT(16) | BIT(17) ,
+//     .setup                  = zoom_twlgpio_setup,
+//};
NAK to //

+static struct twl4030_gpio_platform_data zoom_gpio_data = {
+       .gpio_base      = OMAP_MAX_GPIO_LINES,
+       .irq_base       = TWL4030_GPIO_IRQ_BASE,
+       .irq_end        = TWL4030_GPIO_IRQ_END,
+       .setup          = zoom_twl_gpio_setup,
+};
+
+static struct twl4030_usb_data zoom_usb_data = {
+       .usb_mode               = T2_USB_MODE_ULPI,
+};
+
+/* TODO: enable T2 scripts */
+#if 0
NAK to #if 0 - introduce seperately if not operational.

[...]

diff --git a/arch/arm/mach-omap2/board-zoom2.c b/arch/arm/mach-omap2/board-zoom2.c
old mode 100644
new mode 100755
index 4ad9b94..abcc1ae
--- a/arch/arm/mach-omap2/board-zoom2.c
+++ b/arch/arm/mach-omap2/board-zoom2.c
@@ -1,8 +1,6 @@
 /*
  * Copyright (C) 2009 Texas Instruments Inc.
- * Mikkel Christensen <mlc@xxxxxx>
  *
- * Modified from mach-omap2/board-ldp.c
[Should we loose the history?]
[...]
-static void __init omap_zoom2_init_irq(void)
+static void __init omap_zoom_init_irq(void)
Question on naming.. as raised above.
[...]

--
Regards,
Nishanth Menon
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [Linux Arm (vger)]     [ARM Kernel]     [ARM MSM]     [Linux Tegra]     [Linux WPAN Networking]     [Linux Wireless Networking]     [Maemo Users]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite Trails]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux