On 28/05/2021 09:30, YueHaibing wrote: > Use DEVICE_ATTR_RW() helper instead of plain DEVICE_ATTR(), > which makes the code a bit shorter and easier to read. Acked-by: Peter Ujfalusi <peter.ujfalusi@xxxxxxxxx> > Signed-off-by: YueHaibing <yuehaibing@xxxxxxxxxx> > --- > sound/soc/ti/omap-mcbsp.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/sound/soc/ti/omap-mcbsp.c b/sound/soc/ti/omap-mcbsp.c > index db47981768c5..4479d74f0a45 100644 > --- a/sound/soc/ti/omap-mcbsp.c > +++ b/sound/soc/ti/omap-mcbsp.c > @@ -539,7 +539,7 @@ static ssize_t prop##_store(struct device *dev, \ > return size; \ > } \ > \ > -static DEVICE_ATTR(prop, 0644, prop##_show, prop##_store) > +static DEVICE_ATTR_RW(prop) > > THRESHOLD_PROP_BUILDER(max_tx_thres); > THRESHOLD_PROP_BUILDER(max_rx_thres); > -- Péter