From: Wolfram Sang <wsa+renesas@xxxxxxxxxxxxxxxxxxxx> Date: Sun, 21 Oct 2018 22:00:11 +0200 > I got tired of fixing this in Renesas drivers manually, so I took the big > hammer. Remove this cumbersome code pattern which got copy-pasted too much > already: > > - struct platform_device *pdev = to_platform_device(dev); > - struct ep93xx_keypad *keypad = platform_get_drvdata(pdev); > + struct ep93xx_keypad *keypad = dev_get_drvdata(dev); > > A branch, tested by buildbot, can be found here: > > git://git.kernel.org/pub/scm/linux/kernel/git/wsa/linux.git coccinelle/get_drvdata > > I have been asked if it couldn't be done for dev_set_drvdata as well. I checked > it and did not find one occasion where it could be simplified like this. Not > much of a surprise because driver_data is usually set in probe() functions > which access struct platform_device in many other ways. > > I am open for other comments, suggestions, too, of course. > > Here is the cocci-script I created: ... Series applied to net-next, thanks.