On Wed 2015-03-04 21:36:50, Aaro Koskinen wrote: > On Wed, Mar 04, 2015 at 08:24:19PM +0100, Pavel Machek wrote: > > @@ -1239,8 +1234,8 @@ static long cs_char_ioctl(struct file *file, unsigned int cmd, > > > > if (copy_to_user((void __user *)arg, &ifver, sizeof(ifver))) > > r = -EFAULT; > > - break; > > } > > + break; > > case CS_CONFIG_BUFS: { > > struct cs_buffer_config buf_cfg; > > > > @@ -1249,8 +1244,8 @@ static long cs_char_ioctl(struct file *file, unsigned int cmd, > > r = -EFAULT; > > else > > r = cs_hsi_buf_config(csdata->hi, &buf_cfg); > > - break; > > } > > + break; > > I think having the break inside the block is more readable. > Now the indendation is mess. Half the function does it one way, one the other way. I don't care which way, but it should be consistent. Pavel -- (english) http://www.livejournal.com/~pavelmachek (cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html -- To unsubscribe from this list: send the line "unsubscribe linux-omap" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html