On Mon, 2 Mar 2015 22:03:59 +0100 Pavel Machek <pavel@xxxxxx> wrote: > Hi! > > > + status_changed = > > + (twl->linkstat == OMAP_MUSB_VBUS_VALID || > > + twl->linkstat == OMAP_MUSB_ID_GROUND) > > + != > > + (status == OMAP_MUSB_VBUS_VALID || > > + status == OMAP_MUSB_ID_GROUND); > > twl->linkstat = status; > ... > > @@ -768,6 +770,10 @@ static int twl4030_usb_remove(struct platform_device *pdev) > > > > /* disable complete OTG block */ > > twl4030_usb_clear_bits(twl, POWER_CTRL, POWER_CTRL_OTG_ENAB); > > + > > + if (twl->linkstat == OMAP_MUSB_VBUS_VALID || > > + twl->linkstat == OMAP_MUSB_ID_GROUND) > > + pm_runtime_put_noidle(twl->dev); > > pm_runtime_mark_last_busy(twl->dev); > > inline function returning (x == OMAP_MUSB_VBUS_VALID || x == > OMAP_MUSB_ID_GROUND) would really help readability here. > > Thanks, > Pavel Good idea. I've done that. The function is called "cable_present()". Thanks, NeilBrown
Attachment:
pgp3qW19qY2Ao.pgp
Description: OpenPGP digital signature