2009/2/7 David Brownell <david-b@xxxxxxxxxxx>: > On Friday 06 February 2009, Joonyoung Shim wrote: >> If TWL4030 GPIO pin is output, must read the value from REG_GPIODATAOUTx >> register in twl4030_get_gpio_datainout(). > > Why "must"? The goal is to return the *actual* value of the pin, > not the intended one. When an external signal overwhelms the drive > capability of that GPIO -- just a couple mA -- the correct value > to return can't be the value written in the output register. but, it doesn't return actual value of the pin if twl4030 GPIO pin is output. For example, the GPIO13 pin of twl4030 is configured as an output using gpio_direction_output() and assigns the GPIO's value to 1 using gpio_set_value_cansleep(), the result of "# cat /sys/kernel/debug/gpio" reports to me as follows. GPIOs 192-209, platform/twl4030_gpio, twl4030, can sleep: gpio-205 (keyled ) out lo but it should have reported "hi" instead of "lo". > > Plus, this patch won't even link ... you changed the name of the > function at its definition, but not at its use points. Sorry, i missed some code. > > NAK, unless you can show there's a real bug this addresses... > > - Dave > -- To unsubscribe from this list: send the line "unsubscribe linux-omap" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html