RE: [PATCH RESEND] OMAP: DMA: Cleanup of DMA Request Lines

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi, 
> Most of these ifdefs and ifndefs don't look good to me. It doesn't
> look like a problem
> keeping (for example) both:
> 
> #define OMAP24XX_DMA_VLYNQ_TX          7       /* S_DMA_6 */
> #define OMAP24XX_DMA_EXT_DMAREQ2       7       /* S_DMA_6 */
> 
> to look better one could make this as:
> 
> #define OMAP24XX_DMA_VLYNQ_TX          7       /* S_DMA_6 */
> #define OMAP24XX_DMA_EXT_DMAREQ2       OMAP24XX_DMA_VLYNQ_TX  
>      /* S_DMA_6 */
> 
> but this is a matter of "taste".
> 
> In any case, I think most of these pre-processor condicional
> statements can be removed,
> as long as you're not re-defining a macro with different values for
> different archs. The
> patch would look better by just adding OMAP3, i guess.
> 
> what do you guys think ?
How about naming all the macros as OMAP_ and for each platform define as follows

#ifdef CONFIG_ARCH_OMAP24XX
#define OMAP_DMA_VLYNQ_TX	OMAP_24XX_DMA_VLYNQ_TX
#endif

#ifdef CONFIG_ARCH_OMAP34XX
#define OMAP_DMA_VLYNQ_TX	OMAP_34XX_DMA_VLYNQ_TX
#endif

This way the driver code will not have to change when moving from platform to platform.

Regards,
Rohit
-
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [Linux Arm (vger)]     [ARM Kernel]     [ARM MSM]     [Linux Tegra]     [Linux WPAN Networking]     [Linux Wireless Networking]     [Maemo Users]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite Trails]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux