Re: [PATCH 3/10] hugetlb: factor init_nodemask_of_node

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Fri, 2009-10-02 at 10:48 +0100, Mel Gorman wrote:
> On Thu, Oct 01, 2009 at 12:58:25PM -0400, Lee Schermerhorn wrote:
> > [PATCH 3/10] - hugetlb:  factor init_nodemask_of_node()
> > 
> > Against:  2.6.31-mmotm-090925-1435
> > 
> > New in V5 of series
> > 
> > V6: + rename 'init_nodemask_of_nodes()' to 'init_nodemask_of_node()'
> >     + redefine init_nodemask_of_node() as static inline fcn
> >     + move this patch back 1 in series
> > 
> > V8: + factor 'init_nodemask_of_node()' from nodemask_of_node()
> >     + drop alloc_nodemask_of_node() -- not used any more
> > 
> > Factor init_nodemask_of_node() out of the nodemask_of_node()
> > macro.
> > 
> > This will be used to populate the huge pages "nodes_allowed"
> > nodemask for a single node when basing nodes_allowed on a
> > preferred/local mempolicy or when a persistent huge page
> > pool page count is modified via a per node sysfs attribute.
> > 
> > Signed-off-by: Lee Schermerhorn <lee.schermerhorn@xxxxxx>
> 
> Very minor comment but otherwise
> 
> Acked-by: Mel Gorman <mel@xxxxxxxxx>
> 
> > 
> >  include/linux/nodemask.h |    9 +++++++--
> >  1 file changed, 7 insertions(+), 2 deletions(-)
> > 
> > Index: linux-2.6.31-mmotm-090925-1435/include/linux/nodemask.h
> > ===================================================================
> > --- linux-2.6.31-mmotm-090925-1435.orig/include/linux/nodemask.h	2009-09-30 11:19:52.000000000 -0400
> > +++ linux-2.6.31-mmotm-090925-1435/include/linux/nodemask.h	2009-09-30 11:22:01.000000000 -0400
> > @@ -245,14 +245,19 @@ static inline int __next_node(int n, con
> >  	return min_t(int,MAX_NUMNODES,find_next_bit(srcp->bits, MAX_NUMNODES, n+1));
> >  }
> >  
> > +static inline void init_nodemask_of_node(nodemask_t *mask, int node)
> > +{
> > +	nodes_clear(*(mask));
> 
> () around mask there is unnecessary, you're not in a macro.
> 
> > +	node_set((node), *(mask));
> > +}
> 
> Same for mask and node here. Not world ending by any measure.

Sorry.  Incomplete transformation from macro to function :(

I'll send out incremental fixes to this and the other botched merge that
you pointed out in patch 4/10.  Or I can send out replacement patches.

Andrew:  what's your preference?

Lee 
> 
> > +
> >  #define nodemask_of_node(node)						\
> >  ({									\
> >  	typeof(_unused_nodemask_arg_) m;				\
> >  	if (sizeof(m) == sizeof(unsigned long)) {			\
> >  		m.bits[0] = 1UL<<(node);				\
> >  	} else {							\
> > -		nodes_clear(m);						\
> > -		node_set((node), m);					\
> > +		init_nodemask_of_node(&m, (node));			\
> >  	}								\
> >  	m;								\
> >  })
> > 
> 

--
To unsubscribe from this list: send the line "unsubscribe linux-numa" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [Linux Kernel]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux SCSI]     [Devices]

  Powered by Linux