Re: [PATCH v6 0/2] nilfs2: introduce free inodes count calculation implementation

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Andrew,

Could you queue this patch set for the next merge window?

Thanks,
Ryusuke Konishi

On Wed, 29 May 2013 13:25:53 +0400, Vyacheslav Dubeyko wrote:
> Hi Ryusuke,
> 
> This is sixth version of the patch set.
> 
> v5->v6
>  * Minor corrections in logic of free inodes calculation
>    (remove obsolete increment, align indentations).
>  * Rework patch on using atomic64_t instead of using
>    atomic_long_t (Joern Engel suggestion).
> 
> v4->v5
>  * Remove mi_desc_blocks_count field from nilfs_mdt_info struct.
>  * Remove logic of using mi_desc_blocks_count from the code.
>  * Simplify logic of nilfs_palloc_count_max_entries() method.
>  * Add single patch with changing on atomic_long_t type
>    representation of inodes_count and blocks_count fields in
>    nilfs_root struct.
> 
> v3->v4
>  * The desc_blocks value is represented by unsigned long type.
>  * The nilfs_palloc_count_desc_blocks() method is simplified.
>  * The mi_desc_blocks_count field of nilfs_mdt_info structure
>    is represented as atomic64_t for the case of CONFIG_64BIT and
>    as atomic_t for other cases.
> 
> v2->v3
>  * Trivial BUG_ON checks were removed.
>  * Whole calculation algorithm was moved into
>    nilfs_palloc_count_max_entries() method.
>  * Improve error processing in the code.
>  * The nilfs_palloc_mdt_file_can_grow() method was simplified.
>  * The nilfs_ifile_count_free_inodes() method was simplified.
> 
> v1->v2
>  * Change __statfs_word on u64 type.
>  * Rename nilfs_count_free_inodes() into nilfs_ifile_count_free_inodes()
>    method.
>  * Introduce auxiliary functions: nilfs_palloc_count_max_entries(),
>    nilfs_palloc_count_desc_blocks(), nilfs_palloc_mdt_file_can_grow().
>  * Rework processing of returned error from
>    nilfs_ifile_count_free_inodes() in nilfs_statfs().
> 
> With the best regards,
> Vyacheslav Dubeyko.
> ---
>  fs/nilfs2/alloc.c     |   63 +++++++++++++++++++++++++++++++++++++++++++++++++
>  fs/nilfs2/alloc.h     |    2 ++
>  fs/nilfs2/ifile.c     |   22 +++++++++++++++++
>  fs/nilfs2/ifile.h     |    2 ++
>  fs/nilfs2/inode.c     |    8 +++----
>  fs/nilfs2/segment.c   |    4 ++--
>  fs/nilfs2/super.c     |   31 ++++++++++++++++++++----
>  fs/nilfs2/the_nilfs.c |    4 ++--
>  fs/nilfs2/the_nilfs.h |    4 ++--
>  9 files changed, 126 insertions(+), 14 deletions(-)
> -- 
> 1.7.9.5
> 
> 
> --
> To unsubscribe from this list: send the line "unsubscribe linux-nilfs" in
> the body of a message to majordomo@xxxxxxxxxxxxxxx
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
--
To unsubscribe from this list: send the line "unsubscribe linux-nilfs" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [Linux Filesystem Development]     [Linux BTRFS]     [Linux CIFS]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux SCSI]

  Powered by Linux