Re: [PATCH] NFSD: Replace all non-returning strlcpy with strscpy

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 




> On May 12, 2023, at 7:30 AM, Azeem Shaikh <azeemshaikh38@xxxxxxxxx> wrote:
> 
> Thanks Chuck and Kees for the review.
> 
>>> Actually netid should use the __string() and __assign_str()
>>> macros rather than open-coding a string copy, I think.
> 
> Do you mean something like this?
> 
> diff --git a/fs/nfsd/trace.h b/fs/nfsd/trace.h
> index 4183819ea082..72a906a053dc 100644
> --- a/fs/nfsd/trace.h
> +++ b/fs/nfsd/trace.h
> @@ -1365,19 +1365,19 @@ TRACE_EVENT(nfsd_cb_setup,
>                __field(u32, cl_id)
>                __field(unsigned long, authflavor)
>                __sockaddr(addr, clp->cl_cb_conn.cb_addrlen)
> -               __array(unsigned char, netid, 8)
> +               __string(netid, netid)
>        ),
>        TP_fast_assign(
>                __entry->cl_boot = clp->cl_clientid.cl_boot;
>                __entry->cl_id = clp->cl_clientid.cl_id;
> -               strlcpy(__entry->netid, netid, sizeof(__entry->netid));
> +               __assign_str(netid, netid);
>                __entry->authflavor = authflavor;
>                __assign_sockaddr(addr, &clp->cl_cb_conn.cb_addr,
>                                  clp->cl_cb_conn.cb_addrlen)
>        ),
>        TP_printk("addr=%pISpc client %08x:%08x proto=%s flavor=%s",
>                __get_sockaddr(addr), __entry->cl_boot, __entry->cl_id,
> -               __entry->netid, show_nfsd_authflavor(__entry->authflavor))
> +               __get_str(netid), show_nfsd_authflavor(__entry->authflavor))
> );

Yes. I don't remember why I chose to open-code the string
handling in here.

I agree with Kees, also: __assign_str() needs to handle
the memory accesses properly, and I had assumed it did
that already. My bad. That IMO should be handled as a
separate patch.


>>> Fixes: 3c92fba557c6 ("NFSD: Enhance the nfsd_cb_setup tracepoint")
> 
> Ack.

I agree that it's not a high priority backport. However,
I expect those who want to use trace points on KASAN-
enabled stable kernels might prefer to have the
__assign_str fix in place, along with this one.

So, I'm good with including Fixes: or leaving it off. Up
to you!

--
Chuck Lever






[Index of Archives]     [Linux Filesystem Development]     [Linux USB Development]     [Linux Media Development]     [Video for Linux]     [Linux NILFS]     [Linux Audio Users]     [Yosemite Info]     [Linux SCSI]

  Powered by Linux