On Mon, Feb 08 2021, Steve Dickson wrote: > On 2/7/21 7:30 PM, NeilBrown wrote: >> On Mon, Feb 01 2021, Steve Dickson wrote: >> >>> Signed-off-by: Steve Dickson <steved@xxxxxxxxxx> >>> --- >>> nfs.conf | 2 +- >>> utils/mountd/mountd.c | 3 +++ >>> 2 files changed, 4 insertions(+), 1 deletion(-) >>> >>> diff --git a/nfs.conf b/nfs.conf >>> index 186a5b19..9fcf1bf0 100644 >>> --- a/nfs.conf >>> +++ b/nfs.conf >>> @@ -30,7 +30,7 @@ >>> # udp-port=0 >>> # >>> [mountd] >>> -# debug=0 >>> +# debug="all|auth|call|general|parse" >>> # manage-gids=n >>> # descriptors=0 >>> # port=0 >>> diff --git a/utils/mountd/mountd.c b/utils/mountd/mountd.c >>> index 988e51c5..a480265a 100644 >>> --- a/utils/mountd/mountd.c >>> +++ b/utils/mountd/mountd.c >>> @@ -684,6 +684,9 @@ read_mount_conf(char **argv) >>> if (s && !state_setup_basedir(argv[0], s)) >>> exit(1); >>> >>> + if ((s = conf_get_str("mountd", "debug")) != NULL) >>> + xlog_sconfig(s, 1); >>> + >> >> Why is this needed? >> A few lines higher up is >> xlog_from_conffile("mountd"); >> which calls >> kinds = conf_get_list(service, "debug"); >> and passes each word that it finds to xlog_sconfig() >> ?? >> >> I just tested setting "debug=all" in the mountd section of nfs.conf, >> and it seems to work without this patch. > No it is not... I didn't realize xlog_from_conffile() process > the debug config variable... maybe we should change the name > to something like xlog_debug_conffile()... something more > descriptive as to what it does. > > I will clean it up... in a bit. Thanks. I agree that including "debug" in that function name would help. Maybe "conffile_set_debug()", or your suggestion. Thanks, NeilBrown
Attachment:
signature.asc
Description: PGP signature