These three patches seem fine. To bikeshed just a bit more: On Wed, Jan 06, 2021 at 09:52:35AM +0200, Amir Goldstein wrote: > /* We found a matching entry which is either in progress or done. */ > - nfsdstats.rchits++; > + nfsd_stats_rc_hits_inc(); Maybe make that something like nfsd_stats_inc(NFSD_STATS_RC_HITS); and then we could avoid boilerplate like the below? --b. > +static inline void nfsd_stats_rc_hits_inc(void) > +{ > + percpu_counter_inc(&nfsdstats.counter[NFSD_STATS_RC_HITS]); > +} > + > +static inline void nfsd_stats_rc_misses_inc(void) > +{ > + percpu_counter_inc(&nfsdstats.counter[NFSD_STATS_RC_MISSES]); > +} > + > +static inline void nfsd_stats_rc_nocache_inc(void) > +{ > + percpu_counter_inc(&nfsdstats.counter[NFSD_STATS_RC_NOCACHE]); > +} > + > +static inline void nfsd_stats_fh_stale_inc(void) > +{ > + percpu_counter_inc(&nfsdstats.counter[NFSD_STATS_FH_STALE]); > +} > + > +static inline void nfsd_stats_io_read_add(s64 amount) > +{ > + percpu_counter_add(&nfsdstats.counter[NFSD_STATS_IO_READ], amount); > +} > + > +static inline void nfsd_stats_io_write_add(s64 amount) > +{ > + percpu_counter_add(&nfsdstats.counter[NFSD_STATS_IO_WRITE], amount); > +} > + > +static inline void nfsd_stats_payload_misses_inc(struct nfsd_net *nn) > +{ > + percpu_counter_inc(&nn->counter[NFSD_NET_PAYLOAD_MISSES]); > +} > + > +static inline void nfsd_stats_drc_mem_usage_add(struct nfsd_net *nn, s64 amount) > +{ > + percpu_counter_add(&nn->counter[NFSD_NET_DRC_MEM_USAGE], amount); > +} > + > +static inline void nfsd_stats_drc_mem_usage_sub(struct nfsd_net *nn, s64 amount) > +{ > + percpu_counter_sub(&nn->counter[NFSD_NET_DRC_MEM_USAGE], amount); > +}