On Sun, 2017-10-01 at 15:30 -0400, Jérémy Lefaure wrote: > Using the ARRAY_SIZE macro improves the readability of the code. > > Found with Coccinelle with the following semantic patch: > @r depends on (org || report)@ > type T; > T[] E; > position p; > @@ > ( > (sizeof(E)@p /sizeof(*E)) > > > > (sizeof(E)@p /sizeof(E[...])) > > > > (sizeof(E)@p /sizeof(T)) > ) > > Signed-off-by: Jérémy Lefaure <jeremy.lefaure@xxxxxxxxxxxx> > --- > fs/nfsd/fault_inject.c | 5 ++--- > 1 file changed, 2 insertions(+), 3 deletions(-) > > diff --git a/fs/nfsd/fault_inject.c b/fs/nfsd/fault_inject.c > index 34c1c449fddf..3ec72c931ac5 100644 > --- a/fs/nfsd/fault_inject.c > +++ b/fs/nfsd/fault_inject.c > @@ -11,6 +11,7 @@ > #include <linux/nsproxy.h> > #include <linux/sunrpc/addr.h> > #include <linux/uaccess.h> > +#include <linux/kernel.h> > > #include "state.h" > #include "netns.h" > @@ -125,8 +126,6 @@ static struct nfsd_fault_inject_op inject_ops[] = > { > }, > }; > > -#define NUM_INJECT_OPS (sizeof(inject_ops)/sizeof(struct > nfsd_fault_inject_op)) > - > int nfsd_fault_inject_init(void) > { > unsigned int i; > @@ -137,7 +136,7 @@ int nfsd_fault_inject_init(void) > if (!debug_dir) > goto fail; > > - for (i = 0; i < NUM_INJECT_OPS; i++) { > + for (i = 0; i < ARRAY_SIZE(inject_ops); i++) { > op = &inject_ops[i]; > if (!debugfs_create_file(op->file, mode, debug_dir, > op, &fops_nfsd)) > goto fail; Reviewed-by: Jeff Layton <jlayton@xxxxxxxxxx> -- To unsubscribe from this list: send the line "unsubscribe linux-nfs" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html