On 06/30/2017 09:21 AM, Stefan Hajnoczi wrote: > Format vsock hosts as "vsock:<cid>" so the addresses can be easily > distinguished from IPv4 and IPv6 addresses. > > Signed-off-by: Stefan Hajnoczi <stefanha@xxxxxxxxxx> > --- > utils/mount/network.c | 8 ++++++++ > 1 file changed, 8 insertions(+) > > diff --git a/utils/mount/network.c b/utils/mount/network.c > index 281e935..b5dcaa5 100644 > --- a/utils/mount/network.c > +++ b/utils/mount/network.c > @@ -45,6 +45,8 @@ > #include <rpc/pmap_prot.h> > #include <rpc/pmap_clnt.h> > > +#include <linux/vm_sockets.h> In the previous patch you had this surrounded by #ifdef AF_VSOCK I'm not keen on sprinkling a bunch ifdefs around since I think it makes the code harder to read. So my question is why is the ifdef need in the previous patch and not needed in this patch and are they needed in the previous patch? steved. > + > #include "sockaddr.h" > #include "xcommon.h" > #include "mount.h" > @@ -325,6 +327,12 @@ int nfs_string_to_sockaddr(const char *address, struct sockaddr *sap, > int nfs_present_sockaddr(const struct sockaddr *sap, const socklen_t salen, > char *buf, const size_t buflen) > { > + if (sap->sa_family == AF_VSOCK) { > + snprintf(buf, buflen, "vsock:%u", > + ((struct sockaddr_vm *)sap)->svm_cid); > + return 1; > + } > + > #ifdef HAVE_GETNAMEINFO > int result; > > -- To unsubscribe from this list: send the line "unsubscribe linux-nfs" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html