I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu <chuansheng.liu@xxxxxxxxx> Signed-off-by: Baole Ni <baolex.ni@xxxxxxxxx> --- fs/nfs/cache_lib.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/fs/nfs/cache_lib.c b/fs/nfs/cache_lib.c index 5f7b053..72422cd 100644 --- a/fs/nfs/cache_lib.c +++ b/fs/nfs/cache_lib.c @@ -25,9 +25,9 @@ static char nfs_cache_getent_prog[NFS_CACHE_UPCALL_PATHLEN] = static unsigned long nfs_cache_getent_timeout = NFS_CACHE_UPCALL_TIMEOUT; module_param_string(cache_getent, nfs_cache_getent_prog, - sizeof(nfs_cache_getent_prog), 0600); + sizeof(nfs_cache_getent_prog), S_IRUSR | S_IWUSR); MODULE_PARM_DESC(cache_getent, "Path to the client cache upcall program"); -module_param_named(cache_getent_timeout, nfs_cache_getent_timeout, ulong, 0600); +module_param_named(cache_getent_timeout, nfs_cache_getent_timeout, ulong, S_IRUSR | S_IWUSR); MODULE_PARM_DESC(cache_getent_timeout, "Timeout (in seconds) after which " "the cache upcall is assumed to have failed"); -- 2.9.2 -- To unsubscribe from this list: send the line "unsubscribe linux-nfs" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html