> On Dec 16, 2015, at 9:00 AM, Sagi Grimberg <sagig@xxxxxxxxxxxxxxxxxx> wrote: > > >> diff --git a/net/sunrpc/xprtrdma/xprt_rdma.h b/net/sunrpc/xprtrdma/xprt_rdma.h >> index 4197191..e60d817 100644 >> --- a/net/sunrpc/xprtrdma/xprt_rdma.h >> +++ b/net/sunrpc/xprtrdma/xprt_rdma.h >> @@ -206,6 +206,8 @@ struct rpcrdma_frmr { >> enum rpcrdma_frmr_state fr_state; >> struct work_struct fr_work; >> struct rpcrdma_xprt *fr_xprt; >> + struct ib_reg_wr fr_regwr; >> + struct ib_send_wr fr_invwr; > > Would it make sense to unionize these as they are guaranteed not to > execute together? Some people don't like this sort of savings. I dislike unions because they make the code that uses them less readable. I can define macros to help that, but sigh! OK. -- Chuck Lever -- To unsubscribe from this list: send the line "unsubscribe linux-nfs" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html