On Tue, Sep 23, 2014 at 02:42:34PM -0500, Steve Wise wrote: > > > > diff --git a/net/sunrpc/xprtrdma/xprt_rdma.h b/net/sunrpc/xprtrdma/xprt_rdma.h > > > index c419498..a9cf5c3 100644 > > > --- a/net/sunrpc/xprtrdma/xprt_rdma.h > > > +++ b/net/sunrpc/xprtrdma/xprt_rdma.h > > > @@ -392,4 +392,8 @@ extern struct kmem_cache *svc_rdma_ctxt_cachep; > > > /* Workqueue created in svc_rdma.c */ > > > extern struct workqueue_struct *svc_rdma_wq; > > > > > > +#define RPCSVC_MAXPAYLOAD_RDMA \ > > > + (RPCSVC_MAXPAYLOAD < (RPCRDMA_MAX_DATA_SEGS << PAGE_SHIFT) ? \ > > > + RPCSVC_MAXPAYLOAD : (RPCRDMA_MAX_DATA_SEGS << PAGE_SHIFT)) > > > + > > > > Couldn't you use: > > > > #if RPCSVC_MAXPAYLOAD < (RPCRDMA_MAX_DATA_SEGS << PAGE_SHIFT) > > #define RPCSVC_MAXPAYLOAD_RDMA RPC_MAXPAYLOAD > > #else > > #define RPCSVC_MAXPAYLOAD_RDMA (RPCRDMA_MAX_DATA_SEGS << PAGE_SHIFT) > > #endif > > > > That seems more idiomatic. > > Sure. That makes it easier to read in my opinion too. > > I'll send out V3 with this change. While we're bikeshedding, why not use min()? --b. -- To unsubscribe from this list: send the line "unsubscribe linux-nfs" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html