On Sun, Oct 27, 2013 at 06:04:09PM +1100, NeilBrown wrote: > ... or just open-code it. Then this becomes: > > if (!IS_ROOT(find_disconnected_root(target_dir))) { > clear_disconnected(target_dir); > return 0; > } > return -ESTALE; > > which is pleasing similar to the (new) code higher up: > > struct dentry *pd = find_disconnected_root(target_dir); > > if (!IS_ROOT(pd)) { > /* must have found a connected parent - great */ > clear_disconnected(target_dir); > .... We end up ditching the other call to find_disconnected_root(), and I find dentry_connected() slightly more straightforward here, so I'd prefer to stick with it as is. I could do the above as an intermediate step and then write a separate patch for the !IS_ROOT(find_disconnected_root())->dentry_connected() that makes that argument explicitly if you think that would be clearer? Thanks for the review. --b. -- To unsubscribe from this list: send the line "unsubscribe linux-nfs" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html