On Mon, Nov 21, 2011 at 12:40:20PM -0500, Jeff Layton wrote: > /* > + * Freezer-friendly macro around schedule() in the kernel. > + */ > +#define freezable_schedule() \ > +({ \ > + freezer_do_not_count(); \ > + schedule(); \ > + freezer_count(); \ > +}) So, yes, this seems correct to me but I'm not really sure about the naming. Given what freezable means for other interfaces, this is a bit confusing to me but that could be because I know how each is implemented. Anyone with a better name? Also, this definitely can use a lot more detailed comment. What it's supposed to do, how it's supposed to be used and so on. Thank you. -- tejun -- To unsubscribe from this list: send the line "unsubscribe linux-nfs" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html