On Tue, Feb 8, 2011 at 5:09 PM, Fred Isaman <iisaman@xxxxxxxxxx> wrote: > On Fri, Feb 4, 2011 at 4:33 PM, <andros@xxxxxxxxxx> wrote: >> From: Andy Adamson <andros@xxxxxxxxxx> >> >> Signed-off-by: Andy Adamson <andros@xxxxxxxxxx> >> --- >> include/linux/nfs_xdr.h | 12 ++++-------- >> 1 files changed, 4 insertions(+), 8 deletions(-) >> >> diff --git a/include/linux/nfs_xdr.h b/include/linux/nfs_xdr.h >> index 3b2e488..1222aa9 100644 >> --- a/include/linux/nfs_xdr.h >> +++ b/include/linux/nfs_xdr.h >> @@ -1016,15 +1016,11 @@ struct nfs_read_data { >> unsigned int npages; /* Max length of pagevec */ >> struct nfs_readargs args; >> struct nfs_readres res; >> - struct pnfs_layout_segment *lseg; >> - struct nfs_client *ds_clp; /* pNFS data server */ >> -#ifdef CONFIG_NFS_V4 >> unsigned long timestamp; /* For lease renewal */ >> -#endif >> -#if defined(CONFIG_NFS_V4_1) >> - const struct rpc_call_ops *call_ops; >> - __u64 orig_offset; /* For filelayout dense stripe */ >> -#endif /* CONFIG_NFS_V4_1 */ >> + struct pnfs_layout_segment *lseg; >> + struct nfs_client *ds_clp; /* pNFS data server */ >> + const struct rpc_call_ops *call_ops; /* For pNFS recovery to MDS */ > > The comment is misleading, as it is used for pretty much all file > layout calls, not just recovery. > Perhaps rename the field to mds_call_ops and drop the comment? > >> + __u64 orig_offset; /* Filelayout dense stripe */ > > Also here, mds_offset might be a better name. Good suggestions. -->Andy > > Fred > >> struct page *page_array[NFS_PAGEVEC_SIZE]; >> }; >> >> -- >> 1.6.6 >> >> -- >> To unsubscribe from this list: send the line "unsubscribe linux-nfs" in >> the body of a message to majordomo@xxxxxxxxxxxxxxx >> More majordomo info at http://vger.kernel.org/majordomo-info.html >> > -- > To unsubscribe from this list: send the line "unsubscribe linux-nfs" in > the body of a message to majordomo@xxxxxxxxxxxxxxx > More majordomo info at http://vger.kernel.org/majordomo-info.html > -- To unsubscribe from this list: send the line "unsubscribe linux-nfs" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html