[PATCH] libnsm.a: modify return value to false from 0 at nsm_drop_privileges()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



At nsm_drop_privileges(), for improving readability, unify
the return value.

Signed-off-by: Mi Jinlong <mijinlong@xxxxxxxxxxxxxx>
---
 support/nsm/file.c |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/support/nsm/file.c b/support/nsm/file.c
index e21c7d4..98b47bf 100644
--- a/support/nsm/file.c
+++ b/support/nsm/file.c
@@ -421,7 +421,7 @@ nsm_drop_privileges(const int pidfd)
 	 */
         if (prctl(PR_SET_KEEPCAPS, 1, 0, 0, 0) == -1) {
                 xlog(L_ERROR, "prctl(PR_SET_KEEPCAPS) failed: %m");
-		return 0;
+		return false;
 	}
 
 	if (setgroups(0, NULL) == -1) {
-- 1.7.3.3 

--
To unsubscribe from this list: send the line "unsubscribe linux-nfs" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Linux Filesystem Development]     [Linux USB Development]     [Linux Media Development]     [Video for Linux]     [Linux NILFS]     [Linux Audio Users]     [Yosemite Info]     [Linux SCSI]

  Powered by Linux