Topic branch for fs/exportfs: https://git.kernel.org/pub/scm/linux/kernel/git/cel/linux.git branch: exportfs-next Changes since v3: - is_dot_dotdot() now checks that the file name length > 0 Changes since v2: - Capture the open-coded "is_dot_dotdot" implementation in lookup_one_common() Changes since v1: - Fixes: was dropped from 1/2 - Added a patch to hoist is_dot_dotdot() into linux/fs.h --- Chuck Lever (1): fs: Create a generic is_dot_dotdot() utility Trond Myklebust (1): exportfs: fix the fallback implementation of the get_name export operation fs/crypto/fname.c | 8 +------- fs/ecryptfs/crypto.c | 10 ---------- fs/exportfs/expfs.c | 2 +- fs/f2fs/f2fs.h | 11 ----------- fs/namei.c | 6 ++---- include/linux/fs.h | 13 +++++++++++++ 6 files changed, 17 insertions(+), 33 deletions(-) -- Chuck Lever