On Mon, Dec 11, 2023 at 09:47:35AM +1100, NeilBrown wrote: > Similarly would could wrap __fput_sync() is a more friendly name, but > that would be better if we actually renamed the function. > > void fput_now(struct file *f) > { > __fput_sync(f); > } It is unfriendly *precisely* because it should not be used without a very good reason. It may be the last opened file keeping a lazy-umounted mount alive. It may be taking pretty much any locks, or eating a lot of stack space. It really isn't a general-purpose API; any "more friendly name" is going to be NAKed for that reason alone. Al, very much tempted to send a patch renaming that sucker to __fput_dont_use_that_unless_you_really_know_what_you_are_doing().