On Tue, June 16, 2009 9:08 am, J. Bruce Fields wrote: > + if (host_err >= 0 && stable) > + wait_for_concurrent_writes(file, use_wgather, &host_err); > Surely you want this to be: if (host_err >= 0 && stable && use_wgather) host_err = wait_for_concurrent_writes(file); as - this is more readable - setting last_ino and last_dev is pointless when !use_wgather - we aren't interested in differentiation between non-negative values of host_err. NeilBrown -- To unsubscribe from this list: send the line "unsubscribe linux-nfs" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html