Hi all, Today's linux-next merge of the scsi tree got conflicts in: drivers/ata/ahci.h drivers/ata/sata_mv.c include/linux/libata.h between commit: ce32496ec1ab ("block: simplify tag allocation policy selection") from the block tree and commit: 47c2e30afcec ("scsi: Rename .device_configure() into .sdev_configure()") from the scsi tree. I fixed it up (see below) and can carry the fix as necessary. This is now fixed as far as linux-next is concerned, but any non trivial conflicts should be mentioned to your upstream maintainer when your tree is submitted for merging. You may also want to consider cooperating with the maintainer of the conflicting tree to minimise any particularly complex conflicts. -- Cheers, Stephen Rothwell diff --cc drivers/ata/ahci.h index 06781bdde0d2,75cdf51a7f74..000000000000 --- a/drivers/ata/ahci.h +++ b/drivers/ata/ahci.h @@@ -396,8 -396,8 +396,8 @@@ extern const struct attribute_group *ah .shost_groups = ahci_shost_groups, \ .sdev_groups = ahci_sdev_groups, \ .change_queue_depth = ata_scsi_change_queue_depth, \ - .tag_alloc_policy = BLK_TAG_ALLOC_RR, \ + .tag_alloc_policy_rr = true, \ - .device_configure = ata_scsi_device_configure + .sdev_configure = ata_scsi_sdev_configure extern struct ata_port_operations ahci_ops; extern struct ata_port_operations ahci_platform_ops; diff --cc drivers/ata/sata_mv.c index 21c72650f9cc,caf7b1303d4c..000000000000 --- a/drivers/ata/sata_mv.c +++ b/drivers/ata/sata_mv.c @@@ -672,8 -672,8 +672,8 @@@ static const struct scsi_host_template .dma_boundary = MV_DMA_BOUNDARY, .sdev_groups = ata_ncq_sdev_groups, .change_queue_depth = ata_scsi_change_queue_depth, - .tag_alloc_policy = BLK_TAG_ALLOC_RR, + .tag_alloc_policy_rr = true, - .device_configure = ata_scsi_device_configure + .sdev_configure = ata_scsi_sdev_configure }; static struct ata_port_operations mv5_ops = { diff --cc include/linux/libata.h index be5183d75736,7717f06a548d..000000000000 --- a/include/linux/libata.h +++ b/include/linux/libata.h @@@ -1467,14 -1466,14 +1466,14 @@@ extern const struct attribute_group *at #define ATA_SUBBASE_SHT(drv_name) \ __ATA_BASE_SHT(drv_name), \ .can_queue = ATA_DEF_QUEUE, \ - .tag_alloc_policy = BLK_TAG_ALLOC_RR, \ + .tag_alloc_policy_rr = true, \ - .device_configure = ata_scsi_device_configure + .sdev_configure = ata_scsi_sdev_configure #define ATA_SUBBASE_SHT_QD(drv_name, drv_qd) \ __ATA_BASE_SHT(drv_name), \ .can_queue = drv_qd, \ - .tag_alloc_policy = BLK_TAG_ALLOC_RR, \ + .tag_alloc_policy_rr = true, \ - .device_configure = ata_scsi_device_configure + .sdev_configure = ata_scsi_sdev_configure #define ATA_BASE_SHT(drv_name) \ ATA_SUBBASE_SHT(drv_name), \
Attachment:
pgpTMhs6g3v3D.pgp
Description: OpenPGP digital signature