Hi all, Today's linux-next merge of the slab tree got a conflict in: include/linux/slab.h between commit: 78f5d33f3dd4 ("mm, treewide: rename MAX_ORDER to MAX_PAGE_ORDER") from the mm tree and commit: a9e0b9f27266 ("mm/slab: remove CONFIG_SLAB code from slab common code") from the slab tree. I fixed it up (see below) and can carry the fix as necessary. This is now fixed as far as linux-next is concerned, but any non trivial conflicts should be mentioned to your upstream maintainer when your tree is submitted for merging. You may also want to consider cooperating with the maintainer of the conflicting tree to minimise any particularly complex conflicts. -- Cheers, Stephen Rothwell diff --cc include/linux/slab.h index d63823e518c0,b2015d0e01ad..000000000000 --- a/include/linux/slab.h +++ b/include/linux/slab.h @@@ -308,19 -307,10 +307,10 @@@ static inline unsigned int arch_slab_mi * (PAGE_SIZE*2). Larger requests are passed to the page allocator. */ #define KMALLOC_SHIFT_HIGH (PAGE_SHIFT + 1) -#define KMALLOC_SHIFT_MAX (MAX_ORDER + PAGE_SHIFT) +#define KMALLOC_SHIFT_MAX (MAX_PAGE_ORDER + PAGE_SHIFT) #ifndef KMALLOC_SHIFT_LOW - #define KMALLOC_SHIFT_LOW 5 - #endif - #endif - - #ifdef CONFIG_SLUB - #define KMALLOC_SHIFT_HIGH (PAGE_SHIFT + 1) - #define KMALLOC_SHIFT_MAX (MAX_PAGE_ORDER + PAGE_SHIFT) - #ifndef KMALLOC_SHIFT_LOW #define KMALLOC_SHIFT_LOW 3 #endif - #endif /* Maximum allocatable size */ #define KMALLOC_MAX_SIZE (1UL << KMALLOC_SHIFT_MAX)
Attachment:
pgp7cMjhZIrIP.pgp
Description: OpenPGP digital signature