Hi all, Today's linux-next merge of the seccomp tree got a conflict in: tools/testing/selftests/seccomp/seccomp_bpf.c between commit: 9847d24af95c ("selftests/harness: Refactor XFAIL into SKIP") from the kselftest tree and commits: aae7d264d68b ("selftests/seccomp: Check for EPOLLHUP for user_notif") 11b4beaa0d31 ("selftests/seccomp: Make kcmp() less required") ef332c970dfa ("selftests/seccomp: Rename user_trap_syscall() to user_notif_syscall()") from the seccomp tree. I fixed it up (see below) and can carry the fix as necessary. This is now fixed as far as linux-next is concerned, but any non trivial conflicts should be mentioned to your upstream maintainer when your tree is submitted for merging. You may also want to consider cooperating with the maintainer of the conflicting tree to minimise any particularly complex conflicts. -- Cheers, Stephen Rothwell diff --cc tools/testing/selftests/seccomp/seccomp_bpf.c index b878e8379966,b854a6c5bf49..000000000000 --- a/tools/testing/selftests/seccomp/seccomp_bpf.c +++ b/tools/testing/selftests/seccomp/seccomp_bpf.c @@@ -3079,10 -3043,8 +3055,10 @@@ TEST(get_metadata long ret; /* Only real root can get metadata. */ - if (geteuid()) - XFAIL(return, "get_metadata test requires real root"); + if (geteuid()) { - SKIP(return, "get_metadata requires real root"); ++ SKIP(return, "get_metadata test requires real root"); + return; + } ASSERT_EQ(0, pipe(pipefd));
Attachment:
pgpa8GrNWXqk3.pgp
Description: OpenPGP digital signature