On Wed, Jan 15, 2020 at 09:30:04AM +1100, Stephen Rothwell wrote: > Hi all, > > After merging the btrfs tree, today's linux-next build (powerpc > ppc64_defconfig) produced these warnings: > > fs/btrfs/block-group.c: In function 'exclude_super_stripes': > fs/btrfs/block-group.c:1706:5: warning: 'logical' may be used uninitialized in this function [-Wmaybe-uninitialized] > 1706 | kfree(logical); > | ^~~~~~~~~~~~~~ > fs/btrfs/block-group.c:1691:20: warning: 'stripe_len' may be used uninitialized in this function [-Wmaybe-uninitialized] > 1691 | if (logical[nr] + stripe_len <= cache->start) > | ~~~~~~~~~~~~^~~~~~~~~~~~ > > Introduced by commit > > 767f58cdaf20 ("btrfs: Refactor btrfs_rmap_block to improve readability") > > btrfs_rmap_block() returns zero even if its output arguments are not > assigned to ... maybe the final "return 0" should be "return ret"? Yes that's it, thanks. Updated for-next branch pushed.