Hi Nicholas, Today's linux-next merge of the target-updates tree got a conflict in drivers/target/target_core_tpg.c between commit de06875f0896 ("target: Remove extra percpu_ref_init") from Linus' tree and commit d344f8a15637 ("target: Rename core_tpg_{pre,post}_addlun for clarity") from the target-updates tree. I fixed it up (see below) and can carry the fix as necessary (no action is required). -- Cheers, Stephen Rothwell sfr@xxxxxxxxxxxxxxxx diff --cc drivers/target/target_core_tpg.c index 2a573de19a9f,d1df39a05d88..000000000000 --- a/drivers/target/target_core_tpg.c +++ b/drivers/target/target_core_tpg.c @@@ -656,9 -658,15 +656,9 @@@ static int core_tpg_setup_virtual_lun0( spin_lock_init(&lun->lun_sep_lock); init_completion(&lun->lun_ref_comp); - ret = core_tpg_post_addlun(se_tpg, lun, lun_access, dev); - ret = percpu_ref_init(&lun->lun_ref, core_tpg_lun_ref_release); - if (ret < 0) - return ret; - + ret = core_tpg_add_lun(se_tpg, lun, lun_access, dev); - if (ret < 0) { - percpu_ref_cancel_init(&lun->lun_ref); + if (ret < 0) return ret; - } return 0; }
Attachment:
pgpFRiKYbQx2x.pgp
Description: PGP signature