On Mon, Sep 24, 2012 at 7:02 AM, Stephen Rothwell <sfr@xxxxxxxxxxxxxxxx> wrote: > After merging the akpm tree, today's linux-next build (powerpc > ppc64_defconfig) failed like this: > > drivers/infiniband/hw/mlx4/cm.c: In function 'id_map_alloc': > drivers/infiniband/hw/mlx4/cm.c:228:36: error: 'MAX_ID_MASK' undeclared (first use in this function) > > Caused by commit d7a4e9b679e9 ("IB/mlx4: Add CM paravirtualization") from > the infiniband tree interacting with commit "idr: rename MAX_LEVEL to > MAX_IDR_LEVEL" from the akpm tree. > > I have added the following merge fix patch for today: > > From: Stephen Rothwell <sfr@xxxxxxxxxxxxxxxx> > Date: Mon, 24 Sep 2012 23:57:53 +1000 > Subject: [PATCH] IB/mlx4: fix for MAX_ID_MASK to MAX_IDR_MASK name change > > Signed-off-by: Stephen Rothwell <sfr@xxxxxxxxxxxxxxxx> > --- > drivers/infiniband/hw/mlx4/cm.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/infiniband/hw/mlx4/cm.c b/drivers/infiniband/hw/mlx4/cm.c > index e25e4da..80079e5 100644 > --- a/drivers/infiniband/hw/mlx4/cm.c > +++ b/drivers/infiniband/hw/mlx4/cm.c > @@ -225,7 +225,7 @@ id_map_alloc(struct ib_device *ibdev, int slave_id, u32 sl_cm_id) > ret = idr_get_new_above(&sriov->pv_id_table, ent, > next_id, &id); > if (!ret) { > - next_id = ((unsigned) id + 1) & MAX_ID_MASK; > + next_id = ((unsigned) id + 1) & MAX_IDR_MASK; > ent->pv_cm_id = (u32)id; > sl_id_map_add(ibdev, ent); > } Andrew, any preference on how to handle this merge? Jack/Amir, I wonder if there's some way we can avoid this code entirely? Is an IDR the right structure to use here, or would we be better off with a radix tree maybe (where we can assign our own ID)? - R. -- To unsubscribe from this list: send the line "unsubscribe linux-next" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html