On Thu, 13 Sep 2012 17:44:41 +1000 Stephen Rothwell <sfr@xxxxxxxxxxxxxxxx> wrote: > Hi Andrew, > > After merging the akpm tree, today's linux-next build (x86_64 > allmodconfig) failed like this: > > drivers/thermal/cpu_cooling.c: In function 'get_idr': > drivers/thermal/cpu_cooling.c:89:14: error: 'MAX_ID_MASK' undeclared (first use in this function) > > Caused by commit "idr: rename MAX_LEVEL to MAX_IDR_LEVEL" from the akpm > tree interacting with commit 78edc7cdcf5e ("thermal: add generic cpufreq > cooling implementation") from the thermal tree. > > I have applied the following merge fix patch and can carry it as > necessary. > > ... > > --- a/drivers/thermal/cpu_cooling.c > +++ b/drivers/thermal/cpu_cooling.c > @@ -9,7 +9,7 @@ > * it under the terms of the GNU General Public License as published by > * the Free Software Foundation; version 2 of the License. > * > - * This program is distributed in the hope that it will be useful, but > + * This program is distributed in the hope that it will be useful, butX_ID_MASK > * WITHOUT ANY WARRANTY; without even the implied warranty of > * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU > * General Public License for more details. > @@ -86,7 +86,7 @@ again: > else if (unlikely(err)) > return err; > > - *id = *id & MAX_ID_MASK; > + *id = *id & MAX_IDR_MASK; > return 0; > } Confused. http://ozlabs.org/~akpm/mmotm/broken-out/idr-rename-max_level-to-max_idr_level-fix-3.patch already does this. How did that change get into the wrong place? -- To unsubscribe from this list: send the line "unsubscribe linux-next" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html