Hi Greg, Today's linux-next merge of the usb tree got a conflict in drivers/usb/storage/scsiglue.c between commit 086fa5ff0854c676ec333760f4c0154b3b242616 ("block: Rename blk_queue_max_sectors to blk_queue_max_hw_sectors") from the block tree and commit 628726dbb5ebbec77336019ac4e1f60cf3ba08c1 ("usb-storage: use max_hw_sectors instead of max_sectors") from the usb tree. Just context changes. I fixed it up (see below) and can carry the fix as necessary. -- Cheers, Stephen Rothwell sfr@xxxxxxxxxxxxxxxx diff --cc drivers/usb/storage/scsiglue.c index aadc16b,354c38e..0000000 --- a/drivers/usb/storage/scsiglue.c +++ b/drivers/usb/storage/scsiglue.c @@@ -133,8 -133,8 +133,8 @@@ static int slave_configure(struct scsi_ if (us->fflags & US_FL_MAX_SECTORS_MIN) max_sectors = PAGE_CACHE_SIZE >> 9; - if (queue_max_sectors(sdev->request_queue) > max_sectors) + if (queue_max_hw_sectors(sdev->request_queue) > max_sectors) - blk_queue_max_sectors(sdev->request_queue, + blk_queue_max_hw_sectors(sdev->request_queue, max_sectors); } else if (sdev->type == TYPE_TAPE) { /* Tapes need much higher max_sector limits, so just @@@ -494,9 -494,9 +494,9 @@@ static ssize_t store_max_sectors(struc struct scsi_device *sdev = to_scsi_device(dev); unsigned short ms; - if (sscanf(buf, "%hu", &ms) > 0 && ms <= SCSI_DEFAULT_MAX_SECTORS) { + if (sscanf(buf, "%hu", &ms) > 0) { - blk_queue_max_sectors(sdev->request_queue, ms); + blk_queue_max_hw_sectors(sdev->request_queue, ms); - return strlen(buf); + return count; } return -EINVAL; } -- To unsubscribe from this list: send the line "unsubscribe linux-next" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html