On Tue, 9 Jun 2009, Stephen Rothwell wrote: > Today's linux-next merge of the vfs tree got a conflict in > include/linux/magic.h between commit > 81ebac1be35a2c2fe1f4d3810a8e57d315600a32 ("CUSE: implement CUSE - > Character device in Userspace") from the fuse tree and commit > 5b88aed76b5a1470ec9705c03cf3f0480c018513 ("linux/magic.h: move cramfs > magic out of cramfs_fs.h") from the vfs tree. Hmm, looks like that CUSE_SUPER_MAGIC is an unused remnant from an earlier version of the CUSE patchset. I'll fix that up in the fuse tree. Thanks, Miklos > > Just overlapping additions. I fixed it up (see below) and can carry the > fix as necessary. > -- > Cheers, > Stephen Rothwell sfr@xxxxxxxxxxxxxxxx > > diff --cc include/linux/magic.h > index 4596c9e,192f980..0000000 > --- a/include/linux/magic.h > +++ b/include/linux/magic.h > @@@ -3,11 -3,12 +3,13 @@@ > > #define ADFS_SUPER_MAGIC 0xadf5 > #define AFFS_SUPER_MAGIC 0xadff > -#define AFS_SUPER_MAGIC 0x5346414F > +#define AFS_SUPER_MAGIC 0x5346414F > #define AUTOFS_SUPER_MAGIC 0x0187 > #define CODA_SUPER_MAGIC 0x73757245 > + #define CRAMFS_MAGIC 0x28cd3d45 /* some random number */ > + #define CRAMFS_MAGIC_WEND 0x453dcd28 /* magic number with the wrong endianess */ > -#define DEBUGFS_MAGIC 0x64626720 > +#define CUSE_SUPER_MAGIC 0x43555345 > +#define DEBUGFS_MAGIC 0x64626720 > #define SYSFS_MAGIC 0x62656572 > #define SECURITYFS_MAGIC 0x73636673 > #define TMPFS_MAGIC 0x01021994 > -- To unsubscribe from this list: send the line "unsubscribe linux-next" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html