On Wed, Oct 29, 2008 at 01:25:35AM +0100, Carl Nordbeck wrote: > --- a/drivers/net/usb/usbnet.c > +++ b/drivers/net/usb/usbnet.c > @@ -1205,6 +1205,9 @@ usbnet_probe (struct usb_interface *udev, const struct usb_device_id *prod) > /* WLAN devices should always be named "wlan%d" */ > if ((dev->driver_info->flags & FLAG_WLAN) != 0) > strcpy(net->name, "wlan%d"); > + /* MB devices should always be named "mb%d" */ > + if (dev->driver_info->flags & FLAG_MBN) > + strcpy (net->name, "mb%d"); Why? Why have a different naming scheme only for this type of devices? What makes this necessary? thanks, greg k-h -- To unsubscribe from this list: send the line "unsubscribe linux-net" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html