Joe Perches wrote:
- void *af_packet_priv;
+ struct sock *sk; /* appropriate comment: socket copy? */
AF_PACKET is the only user of this private field, and
I want people to be aware of this and not try to use it
for other stuff.
Nobody else can use it for something different, the code
in net/core/dev.c does specific things when it's non-NULL
knowing that this non-NULL value means that it's an
AF_PACKET packet_type being passed to it.
So we won't make your suggested change.
Even so, why not call it a struct sock*?
It is after all and is used as one.
To discourage other modules from using it, and to keep
programmers who aren't working on AF_PACKET from thinking about it.
It's SOP to use opaque cookies when you want to make data private.
- Dan
--
Dan Kegel
http://www.kegel.com
http://counter.li.org/cgi-bin/runscript/display-person.cgi?user=78045
-
: send the line "unsubscribe linux-net" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html