On Tue, 2 Jun 2020 16:31:24 +0200 Miquel Raynal <miquel.raynal@xxxxxxxxxxx> wrote: > +void nand_ecc_read_user_conf(struct nand_device *nand) This function is not introduced in this patch, but I'm commenting here. Looks like it only operates on an OF node, so how about naming it of_get_nand_ecc_config(). > +{ > + struct device_node *dn = nanddev_get_of_node(nand); > + int strength, size; > + > + nand->ecc.user_conf.engine_type = of_get_nand_ecc_engine_type(dn); > + nand->ecc.user_conf.algo = of_get_nand_ecc_algo(dn); > + nand->ecc.user_conf.placement = of_get_nand_ecc_placement(dn); > + > + strength = of_get_nand_ecc_strength(dn); > + if (strength >= 0) > + nand->ecc.user_conf.strength = strength; > + > + size = of_get_nand_ecc_step_size(dn); > + if (size >= 0) > + nand->ecc.user_conf.step_size = size; > + > + if (of_get_nand_ecc_maximize(dn)) > + nand->ecc.user_conf.flags |= NAND_ECC_MAXIMIZE; > +} > +EXPORT_SYMBOL(nand_ecc_read_user_conf); ______________________________________________________ Linux MTD discussion mailing list http://lists.infradead.org/mailman/listinfo/linux-mtd/