Hi Boris, Boris Brezillon <boris.brezillon@xxxxxxxxxxxxx> wrote on Wed, 27 May 2020 00:55:18 +0200: > On Tue, 26 May 2020 21:56:21 +0200 > Miquel Raynal <miquel.raynal@xxxxxxxxxxx> wrote: > > > Now that the misleading mix between ECC engine type and OOB placement > > has been addressed, add a new enumeration to properly define ECC types > > (also called provider or mode). > > Let's pick a name and stick to it. I think "ECC provider type" or > "ECC engine type" are good names. > > > > > Signed-off-by: Miquel Raynal <miquel.raynal@xxxxxxxxxxx> > > Reviewed-by: Boris Brezillon <boris.brezillon@xxxxxxxxxxxxx> > > --- > > drivers/mtd/nand/raw/nand_base.c | 7 +++++++ > > include/linux/mtd/rawnand.h | 16 ++++++++++++++++ > > 2 files changed, 23 insertions(+) > > > > diff --git a/drivers/mtd/nand/raw/nand_base.c b/drivers/mtd/nand/raw/nand_base.c > > index 515cd4681660..5c6ab5b93270 100644 > > --- a/drivers/mtd/nand/raw/nand_base.c > > +++ b/drivers/mtd/nand/raw/nand_base.c > > @@ -5018,6 +5018,13 @@ static const char * const nand_ecc_modes[] = { > > [NAND_ECC_ON_DIE] = "on-die", > > }; > > > > +static const char * const nand_ecc_engine_providers[] = { > > I'd rename that one nand_ecc_engine_types or nand_ecc_provider_types. > > > + [NAND_ECC_ENGINE_NONE] = "none", > > + [NAND_ECC_ENGINE_SOFT] = "soft", > > + [NAND_ECC_ENGINE_CONTROLLER] = "hw", > > + [NAND_ECC_ENGINE_ON_DIE] = "on-die", > > +}; > > + > > static const char * const nand_ecc_placement[] = { > > [NAND_ECC_PLACEMENT_INTERLEAVED] = "interleaved", > > }; > > diff --git a/include/linux/mtd/rawnand.h b/include/linux/mtd/rawnand.h > > index dc909fb977c7..a2078c5f3d21 100644 > > --- a/include/linux/mtd/rawnand.h > > +++ b/include/linux/mtd/rawnand.h > > @@ -92,6 +92,22 @@ enum nand_ecc_mode { > > NAND_ECC_ON_DIE, > > }; > > > > +/** > > + * enum nand_ecc_engine_type - NAND ECC engine type/provider > > + * @NAND_ECC_ENGINE_INVALID: Invalid value > > + * @NAND_ECC_ENGINE_NONE: No ECC correction > > + * @NAND_ECC_ENGINE_SOFT: Software ECC correction > > + * @NAND_ECC_ENGINE_CONTROLLER: Hardware controller ECC correction > > + * @NAND_ECC_ENGINE_ON_DIE: On chip hardware ECC correction > > + */ > > +enum nand_ecc_engine_type { > > Looks like you went for ecc_engine_type here, so let's stick to that. Ok > > > + NAND_ECC_ENGINE_INVALID, > > NAND_ECC_ENGINE_TYPE_xxx Ok > > > + NAND_ECC_ENGINE_NONE, > > Do we really need a value for NONE? I'd expect the engine type to be > applicable to NAND that have some sort of ECC engine connected to them. For debugging purposes it makes sense. > > > + NAND_ECC_ENGINE_SOFT, > > + NAND_ECC_ENGINE_CONTROLLER, > > + NAND_ECC_ENGINE_ON_DIE, > > +}; > > + > > /** > > * enum nand_ecc_placement - NAND ECC placement > > * @NAND_ECC_PLACEMENT_FREE: The driver can decide where to put ECC bytes. > ______________________________________________________ Linux MTD discussion mailing list http://lists.infradead.org/mailman/listinfo/linux-mtd/