> > 2.) When the block after a conditional is multiple lines, could you please > > include the curly braces? That is: > > > > if (ctrl1 & CAFE_NAND_CTRL1_HAS_DATA_IN) { > > cafe_read_buf(chip, > > subop->instrs[data_instr].ctx.data.buf.in + > > nand_subop_get_data_start_off(subop, data_instr), > > nand_subop_get_data_len(subop, data_instr)); > > } > > > > Instead of: > > > > if (ctrl1 & CAFE_NAND_CTRL1_HAS_DATA_IN) > > cafe_read_buf(chip, > > subop->instrs[data_instr].ctx.data.buf.in + > > nand_subop_get_data_start_off(subop, data_instr), > > nand_subop_get_data_len(subop, data_instr)); > > > > This makes things significantly easier to read for me, not to mention that it > > comes handy to have the braces around for printf debugging. > > I do prefer the version without brackets, but given you debugged it, > I'd be okay changing that one ;-) (assuming Miquel is okay with that > too, of course). I also prefer having curly braces around single-multiline-instructions :) ______________________________________________________ Linux MTD discussion mailing list http://lists.infradead.org/mailman/listinfo/linux-mtd/