On Mon, 27 Apr 2020 17:17:19 +0200 Miquel Raynal <miquel.raynal@xxxxxxxxxxx> wrote: > > + NAND_OP_PARSER_PATTERN(atmel_hsmc_exec_waitrdy, > > + NAND_OP_PARSER_PAT_WAITRDY_ELEM(false)), > > +); > > + > > +static int atmel_hsmc_nand_exec_op(struct atmel_nand *nand, > > + const struct nand_operation *op, > > + bool check_only) > > +{ > > + int ret; > > + > > + if (check_only) > > + return nand_op_parser_exec_op(&nand->base, > > + &atmel_hsmc_op_parser, op, true); > > + > > + atmel_hsmc_nand_select_die(nand, op->cs); > > + ret = nand_op_parser_exec_op(&nand->base, &atmel_hsmc_op_parser, op, > > + false); > > + atmel_hsmc_nand_unselect_die(nand); > > + > > + return ret; > > } > > > > With the above fixed, please add my > > Reviewed-by: Miquel Raynal <miquel.raynal@xxxxxxxxxxx> One, more thing. I'll probably split the conversion in 2 steps to make the diffstat more readable (add exec_op() + get rid of legacy implem). That's what I did for the bcm47xx driver and I find it easier to review. Let me know if you'd rather keep things as they are now. ______________________________________________________ Linux MTD discussion mailing list http://lists.infradead.org/mailman/listinfo/linux-mtd/