Re: [PATCH] mtd: rawnand: atmel: switch to using devm_fwnode_gpiod_get()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Alexandre,

On Fri, Jan 03, 2020 at 10:07:04AM +0100, Alexandre Belloni wrote:
> Hi,
> 
> On 02/01/2020 17:22:38-0800, Dmitry Torokhov wrote:
> > devm_fwnode_get_index_gpiod_from_child() is going away as the name is
> > too unwieldy, let's switch to using the new devm_fwnode_gpiod_get().
> > 
> > Signed-off-by: Dmitry Torokhov <dmitry.torokhov@xxxxxxxxx>
> > ---
> >  drivers/mtd/nand/raw/atmel/nand-controller.c | 20 ++++++++++----------
> >  1 file changed, 10 insertions(+), 10 deletions(-)
> > 
> > diff --git a/drivers/mtd/nand/raw/atmel/nand-controller.c b/drivers/mtd/nand/raw/atmel/nand-controller.c
> > index 8d6be90a6fe8a..849bd5f16492d 100644
> > --- a/drivers/mtd/nand/raw/atmel/nand-controller.c
> > +++ b/drivers/mtd/nand/raw/atmel/nand-controller.c
> > @@ -1578,9 +1578,8 @@ static struct atmel_nand *atmel_nand_create(struct atmel_nand_controller *nc,
> >  
> >  	nand->numcs = numcs;
> >  
> > -	gpio = devm_fwnode_get_index_gpiod_from_child(nc->dev, "det", 0,
> > -						      &np->fwnode, GPIOD_IN,
> > -						      "nand-det");
> > +	gpio = devm_fwnode_gpiod_get(nc->dev, of_fwnode_hanlde(np),
> 
> Shouldn't that be of_fwnode_handle(np)?

:( You are right. Apparently I did not actually enable the driver when
trying to compile this. I'll update and repost this shortly.

-- 
Dmitry

______________________________________________________
Linux MTD discussion mailing list
http://lists.infradead.org/mailman/listinfo/linux-mtd/



[Index of Archives]     [LARTC]     [Bugtraq]     [Yosemite Forum]     [Photo]

  Powered by Linux