On Thu, 6 Sep 2018 10:49:21 +0200 Marcel Ziswiler <marcel@xxxxxxxxxxxx> wrote: > From: Marcel Ziswiler <marcel.ziswiler@xxxxxxxxxxx> > > Reorder NAND manufacturer ids for clarity. > > Signed-off-by: Marcel Ziswiler <marcel.ziswiler@xxxxxxxxxxx> > > --- > > drivers/mtd/nand/raw/nand_ids.c | 20 ++++++++++---------- > include/linux/mtd/rawnand.h | 8 ++++---- > 2 files changed, 14 insertions(+), 14 deletions(-) > > diff --git a/drivers/mtd/nand/raw/nand_ids.c b/drivers/mtd/nand/raw/nand_ids.c > index 5423c3bb388e..0851cd86bf19 100644 > --- a/drivers/mtd/nand/raw/nand_ids.c > +++ b/drivers/mtd/nand/raw/nand_ids.c > @@ -169,21 +169,21 @@ struct nand_flash_dev nand_flash_ids[] = { > > /* Manufacturer IDs */ > static const struct nand_manufacturer nand_manufacturers[] = { > - {NAND_MFR_TOSHIBA, "Toshiba", &toshiba_nand_manuf_ops}, > + {NAND_MFR_AMD, "AMD/Spansion", &amd_nand_manuf_ops}, > + {NAND_MFR_ATO, "ATO"}, > + {NAND_MFR_EON, "Eon"}, > {NAND_MFR_ESMT, "ESMT"}, > - {NAND_MFR_SAMSUNG, "Samsung", &samsung_nand_manuf_ops}, > {NAND_MFR_FUJITSU, "Fujitsu"}, > - {NAND_MFR_NATIONAL, "National"}, > - {NAND_MFR_RENESAS, "Renesas"}, > - {NAND_MFR_STMICRO, "ST Micro"}, > {NAND_MFR_HYNIX, "Hynix", &hynix_nand_manuf_ops}, > - {NAND_MFR_MICRON, "Micron", µn_nand_manuf_ops}, > - {NAND_MFR_AMD, "AMD/Spansion", &amd_nand_manuf_ops}, > + {NAND_MFR_INTEL, "Intel"}, > {NAND_MFR_MACRONIX, "Macronix", ¯onix_nand_manuf_ops}, > - {NAND_MFR_EON, "Eon"}, > + {NAND_MFR_MICRON, "Micron", µn_nand_manuf_ops}, > + {NAND_MFR_NATIONAL, "National"}, > + {NAND_MFR_RENESAS, "Renesas"}, > + {NAND_MFR_SAMSUNG, "Samsung", &samsung_nand_manuf_ops}, > {NAND_MFR_SANDISK, "SanDisk"}, > - {NAND_MFR_INTEL, "Intel"}, > - {NAND_MFR_ATO, "ATO"}, > + {NAND_MFR_STMICRO, "ST Micro"}, > + {NAND_MFR_TOSHIBA, "Toshiba", &toshiba_nand_manuf_ops}, > {NAND_MFR_WINBOND, "Winbond"}, > }; > > diff --git a/include/linux/mtd/rawnand.h b/include/linux/mtd/rawnand.h > index efb2345359bb..ca134851d211 100644 > --- a/include/linux/mtd/rawnand.h > +++ b/include/linux/mtd/rawnand.h > @@ -1541,12 +1541,12 @@ nand_manufacturer_name(const struct nand_manufacturer *manufacturer) > > extern struct nand_flash_dev nand_flash_ids[]; > > -extern const struct nand_manufacturer_ops toshiba_nand_manuf_ops; > -extern const struct nand_manufacturer_ops samsung_nand_manuf_ops; > -extern const struct nand_manufacturer_ops hynix_nand_manuf_ops; > -extern const struct nand_manufacturer_ops micron_nand_manuf_ops; > extern const struct nand_manufacturer_ops amd_nand_manuf_ops; > +extern const struct nand_manufacturer_ops hynix_nand_manuf_ops; > extern const struct nand_manufacturer_ops macronix_nand_manuf_ops; > +extern const struct nand_manufacturer_ops micron_nand_manuf_ops; > +extern const struct nand_manufacturer_ops samsung_nand_manuf_ops; > +extern const struct nand_manufacturer_ops toshiba_nand_manuf_ops; I'm okay with this kind of alphabetic reordering, but why not reordering the macro definitions too? ______________________________________________________ Linux MTD discussion mailing list http://lists.infradead.org/mailman/listinfo/linux-mtd/