dosemu: trouble with himem.sys and rs232

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



I installed dosemu into a gentoo system in order to be able to compile
dsp code and to communicate with a Debug-EVM dsp56002 board.

It is:
DOSEMU (2013-01-07), configured: 2019-10-03 14:39:41 +0200
FreeDOS kernel build 2036 cvs [version Aug 18 2006 compiled Aug 18 2006]

For that, I have an usb<->serial adapter on /dev/ttyUSB0. It seam to
work, I can send mode commands, as example, after

mode com1 baudhard=19200 N 8 1
UART is 16450 or newer. Programming baud rate:
Maximum baud rate is 115200 (BAUDHARD=1152).
 no parity, 1 stop bit, 8 bit, 2400 baud, RTS on, DTR on.

stty in linux show a change to 2400 baud (was 9600 before running
dosemu and the mode command:

stty -F /dev/ttyUSB0
speed 2400 baud; line = 0;

mode com1 baudhard=192 N 8 1
UART is 16450 or newer. Programming baud rate:
 19200 (divisor 6).
Forcing RTS/DTR on.

stty show a change to 19200 baud, which is the only speed the dsp board
can do. If I run its software, I get:

EVM-56K rev. 1.05.1
(c) 1994, Domain Technologies, Inc.
Can not initialize DSP56002 EVM

and stty show a rate change to 2400 baud.

I am a little bit lost here, also because mode is not consistent if I
abbreviate or not the baud rate. Also, the help does not explain the
difference between baud and baudhard.

If I want to update freedos to the last version, is it enough to just
download it and to copy the file over the existing installation?

# # #

Next is the assembler software named asm56k. You can download both
software from here:

it's the file It is a more recent version than mine. I try
both with the same result: a complete dosemu crash.

Both versions of asm56k work with a dos6.22 install in virtualbox.

Before I make a bug report, I want to be sure it is necessary because
asm56k on the dos 6.22 need both himem.sys which provide umb memory and

For now, I cannot get himem.sys to work in dosemu.

It is the original gentoo config, I copied /etc/dosemu/dosemu.conf to
~/.dosemurc and try a lot of things with the memory settings in ordeer
to get some umb memory, but without success.

My config.sys is:
rem config.sys for DOSEMU + FreeDOS
rem note that the initial "D:" is set to "Z:" at the end
install=d:\dosemu\ z: linux\fs\${DOSEMU_LIB_DIR}/drive_z ro
shellhigh=z:\ /e:1024 /p

but each time dosemu is starting, I just get:
CONFIG.SYS error in line 9

That seam very strange to me because it can access config.sys which is
in the same dosemu c: drive.

@echo off
rem autoexec.bat for DOSEMU + FreeDOS
path z:\bin;z:\gnu;z:\dosemu
set HELPPATH=z:\help
set TEMP=c:\tmp
set DOS4GVM=deleteswap maxmem#8192
prompt $P$G
unix -s DOSDRIVE_D
if "%DOSDRIVE_D%" == "" goto nodrived
lredir del d: > nul
lredir d: linux\fs%DOSDRIVE_D%
lredir f: linux\fs/media/cdrom c
rem lredir a: linux\fs/home/dom/evm56k/DSP56K c
lredir e: linux\fs/home/dom/.dosemu/drive_e
echo "Welcome to dosemu %DOSEMU_VERSION%!"
unix -e
path %path%;C:\;C:\DOS;D:\;D:\DOSEMU;
cd evm
mode com1 baudhard=19200 N 8 1
set DOS16m=0
set DOS4GVM=deleteswap maxmem#8192

That's it! Thanks for your time and any help will be appreciated.

If you have a problem and you are not doing anything to fix it, you are
at the heart of the problem.

[Index of Archives]     [Linux Console]     [Linux Audio]     [Linux for Hams]     [Kernel Newbies]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite Camping]     [Yosemite Hiking]     [MIPS Linux]     [ARM Linux]     [Linux RAID]     [Samba]     [Linux Media]     [Fedora Users]

  Powered by Linux