Peculiar build fialure (sh "set" output appears during configuration)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Okay, my previous dosemu issues gone (thank you, list and IRC
helpers!), I tried to move things to a new machine.  When trying to
build dosemu, I got a failure.  The most obvious symptom (ie, what was
visible at the end of the build) was trouble compiling int.c:

gcc -c -MP -MMD -I../../../src/include -I../../../src/plugin/include  -Wall -Wstrict-prototypes -Wmissing-declarations -Wnested-externs -Wno-unused-result  -fno-strict-aliasing -pipe -O2 -fomit-frame-pointer -o int.o int.c
int.c: In function 'dos_helper':
"int.c", line 211:26: error: invalid type argument of unary '*' (have 'int')
     LWORD(ebx) = VERSION * 0x100 + SUBLEVEL; /* major version 0.49 -> 0049 */

(plus some more cascading error messages).

This made it look to me as though VERSION was defined as an empty
string (I don't see how that * is unary otherwise).  It also created a
directory named ... whereas the working one created a similar directory
named, which looks to me as though all four parts of the
version number came out zero-length somehow - which matches well with
VERSION being an empty string.

So I did a build capturing the output and diffed it against a log of a
successful build on the other machine.  A few not-entirely-surprising
differences, but then it went wonky.  Here's the beginning of the diff:

--- failing	Wed Jul 24 17:24:37 2013
+++ working	Wed Jul 24 17:24:38 2013
@@ -48,15 +48,16 @@
 checking for connect... yes
 checking for remove... yes
 checking for shmat... yes
-checking for IceConnectionNumber in -lICE... no
+checking for IceConnectionNumber in -lICE... yes
 checking for XOpenDisplay in -lX11... yes
 configure: Compiling with X support...
-checking for XShmPutImage in -lXext... no
+checking for XShmPutImage in -lXext... yes
+checking for X11/extensions/XShm.h... yes
 configure: Compiling without the XF86 video mode extension
 checking for bdftopcf... yes
 checking for mkfontdir... yes
 configure: Allowing EXPERIMENTAL stuff to be configured...
-configure: Including plugins:  plugin/kbd_unicode plugin/commands plugin/midimisc plugin/sdl plugin/extra_charsets plugin/translate plugin/translate/charsets plugin/X...
+configure: Including plugins:  plugin/sdl plugin/extra_charsets plugin/kbd_unicode plugin/translate plugin/translate/charsets plugin/X plugin/commands plugin/midimisc...
 configure: Compiling without debug info...
 configure: Compiling with ASPI support...
 configure: Compiling with SB Emulation...
@@ -64,629 +65,35 @@
 configure: Linux Specific build options...
 configure: Compiling with network support...
 configure: Compiling with default target CPU...
-checking for the version of gcc...... 5004
+checking for the version of gcc...... 4006
 using -fno-strict-aliasing to work around bugs
-checking for glibc...... ASPI_SUPPORT=ASPI_SUPPORT=1

...followed by the rest of "set" output in some sh-derivative shell,
presumably bash.  It went downhill from there.  I have the full
logfiles, of course, and can make them available if that would help.

This was with a fresh checkout from the same git commit that worked
fine on the other machine, so I have little doubt that the starting
source trees are the same.  (It's commit
400b188991411f34e8df5d7eff3d184b4e358d8c in the tree I mentioned last
time around. git://

Both machines are running Linux - I'm told the working machine is
Ubuntu 12 and the failing one is Mint 18, though I don't know either
enough to be sure what that means (I'm not familiar with the
differences among the various flavours of Linux).

I'm wondering if this is something I've done wrong, something wrong in
dosemu, something wrong in the failing system, or what.  I'd welcome
any thoughts anyone would care to share.

/~\ The ASCII				  Mouse
\ / Ribbon Campaign
 X  Against HTML		mouse@xxxxxxxxxxxxxxxxxxxx
/ \ Email!	     7D C8 61 52 5D E7 2D 39  4E F1 31 3E E8 B3 27 4B
To unsubscribe from this list: send the line "unsubscribe linux-msdos" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at

[Index of Archives]     [Linux Console]     [Linux Audio]     [Linux for Hams]     [Kernel Newbies]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite Camping]     [Yosemite Hiking]     [MIPS Linux]     [ARM Linux]     [Linux RAID]     [Samba]     [Linux Media]     [Fedora Users]

  Powered by Linux