Re: same distro, svn1999 DOSEMU crashes on some PCs on SEGV, on others run fine

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


solarflow99 wrote:
> there is an rpm built for Fedora14 in rpmfusion also, I don't know if
> that will help this problem or not, but others use it without problems
> in case your compiled version has some kind of difference.
> Hope this helps..
> On Mon, Dec 13, 2010 at 4:28 PM, Frantisek Hanzlik <franta@xxxxxxxxxxx> wrote:
>> Hello all DOSEMU gurus,
>> I encounter weird problem with DOSEMU when trying run it on Fedora 14 i386 -
>> althougt machines are roughly same (HW: P4+/2-4GB RAM/max 3 years old, SW:
>> Fedora 14 i686 up-to-date), on some (6 of these i tried) PCs dosemu seems work
>> fine, on others (i found 5 pieces) dosemu crashes on SIGSEGV shortly after
>> start, in its initialization phase.
>> All PCs are installed from same RPM package, which I compile on one of this
>> PCs, then dosemu/freedos part is at all PCs same too. On all machines dosemu
>> run in vm86 mode ($_cpu_emu = "off", and vm.mmap_min_addr = 0).
>> I tried built dosemu both with dynamically loaded plugins and without them,
>> dosemu behavior not changed. After i add some debug messages to several dosemu
>> modules, dosemu on those five machines crashes in slightly different point,
>> and on six remaining machines work still fine.
>> Unfortunately I'm not C programmer and have no idea how debug and solve this
>> problem. For me this appear as dosemu somewhere before overwrite part its
>> memory. Or maybe want some illegal access to pages which was previously locked
>> by mprotect(). But I not know which is right way for solving this issue, know
>> it anyone?
>> When I run dosemu under gdb, on PCs where it crashes i'm getting this output
>> (sorry for it's length):
>> ...

Hello solarflow99,

thank You for reference at Your build. It would be best when dosemu has been
available directly in Fedora main repo. Or at least regularly in rpmfusion.

I solved this problem (with help in our national Linux forum) - there is
probably some fault in Linux glibc/dynamic loader (, which isn't capable
resolve references. (Fedora 14 has still glibc with suspicious version
2.12.90, to full-2.13 probably something is absent).

Problem can be now temporarily solved by using:

1) "LD_BIND_NOW=y dosemu"	# LD_BIND_NOW value doesn't matter, should be defined

2) linking dosemu with option "-Wl,-z now"
To unsubscribe from this list: send the line "unsubscribe linux-msdos" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at

[Index of Archives]     [Linux Console]     [Linux Audio]     [Linux for Hams]     [Kernel Newbies]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite Camping]     [Yosemite Hiking]     [MIPS Linux]     [ARM Linux]     [Linux RAID]     [Samba]     [Linux Media]     [Fedora Users]

  Powered by Linux