trouble with Generic Cadd on 1.3.3/FC5-X86_64

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


I spoke a bit soon about the success of 1.3.3 on the 64-bit FC5 platform
after turning off NX. Dosemu runs fine, editors run fine, but the program
for which I actually NEED Dosemu does not. I have been using Generic Cadd
for 24 years as my primary design tool, and previous dosemus have supported it essentially flawlessly. It crashes immediately with the
current installation, taking dosemu with it--ie it returns to the linux
shell prompt, or if started from an icon simply disappears.

The program can use XMS and/or EMS memory for drawings, but does not itself run in protected mode. I have turned off both XMS and EMS access with no change in behavior. It crashes with either the rudimentary autoexec.bat and config.sys which comes with dosemu or my rather more complicated one. It is configured normally to talk to a VESA- compatible adapter (which has always worked) but behaves exactly the same way when configured to talk to an ordinary VGA. It crashes with exactly the same behavior when run from xdosemu or from dosemu from a console. I thought perhaps there was some SELINUX interaction, but the behavior is the same with any of the three modes of SELINUX including completely off. The only hint of anything wrong in the boot.log file before the bomb is the inability to open a TAP device (?) because of insufficient priviledge, but the behavior is precisely the same when I set up dosemu and run as root (the remark about the TAP device is no longer present in boot.log).

The program comes with a little executable to test the graphics video, and it works fine, as does the configuration program. The first I believe is
significant and makes it unlikely that there is some hardware video

I have no idea, of course, whether this is a 1.3.3 problem or a
64-bit vm86 problem or neither. In any case, the program works fine
on a variety of platforms under 1.2.2 and has done since I first
tried it under 1.0.something when I migrated to Linux several years ago.

The boot.log from the simplest setup run from root is quoted below.

Again, any help would be much appreciated; this is the last barrier
to moving to a 64-bit machine.


--jim gunn


CONF: config variable parser_version_3 set
CONF: config variable c_system set
CONF: Parsing built-in dosemu.conf file.
CONF: config variable version_3_style_used set
CONF: Parsing built-in global.conf file.
CONF: config variable version_3_style_used unset
CONF: config variable version_3_style_used set
CONF: opened include file /etc/dosemu/dosemu.conf
CONF: closed include file /etc/dosemu/dosemu.conf
CONF: mapping driver = 'auto'
debug flags: -a+cw
CONF: Disabling use of pentium timer
CONF: dosbanner on
CONF: timer freq=18, update=54925
CONF: CPU set to 386
CONF: CPUEMU set to 0 for 386
CONF: 8192k bytes XMS memory
CONF: 2048k bytes EMS memory
CONF: EMS-frame = 0xe400
CONF: DPMI-Server on (0x5000)
CONF: DPMI base addr = 0x10000000
CONF: PM DOS API Translator on
CONF: No DJGPP NULL deref checks: off
CONF: dosemu running on X
CONF: x keycode keycode 2 mode13fact 2 gamma 100 font '' mgrab_key "Home"
CONF: time mode = 'bios'
SER: directory /var/lock namestub LCK.. binary No
MOUSE: no device specified, type 0 using internaldriver: yes, emulate3buttons: no baudrate: 0
CONF: Keyboard-layout keyb-user
CONF: **** Warning: floppy /dev/fd0 not accessable, disabled
CONF: fastfloppy = 1
CONF: IPX support off
CONF(LPT0) f: (null)   c: lpr -l  t: 20  port: 0
CONF(LPT1) f: (null)   c: lpr -l -P lpt2  t: 20  port: 0
CONF(LPT2) f: (null)   c: lpr -l -P lpt3  t: 20  port: 0
CONF: not allowing speaker port access
CONF: Packet Driver enabled.
device: /root/.dosemu/drives/c type 4 h: -1  s: -1   t: -1 drive C:
CONF: config variable c_system unset
Linux kernel 2.6.15; CPU speed is 2210791000 Hz
CPU-EMU speed is 2211 MHz
CONF: running exclusively as ROOT: uid=0 (cached 0) gid=0 (cached 0)
DBG_FD already set
DOSEMU- is coming up on Linux version 2.6.15-1.2054_FC5
WARN: vm86plus service not available in your kernel
WARN: using CPU emulation for vm86()
CONF: reserving 640Kb at 0x00000 for 'd' (Base DOS memory (first 640K))
CONF: reserving 48Kb at 0xF4000 for 'r' (Dosemu reserved area)
CPU: Stack bottom 0xfffec000, top 0xffffe000, esp=0xfffed460
major = 136 minor = 0
CONF: reserving 128Kb at 0xA0000 for 'v' (Video memory)
Registering HWRAM, type=g ALRM timer
======================= ENTER CPU-EMU ===============

============ Force node closing at 00002911(08679bb7)
============ Force node closing at 00002921(0867b3f7)
============ Force node closing at 00002921(0863b72f)
============ Force node closing at 00002941(0863c3df)
leavedos(36864|0x9000) called - shutting down
======================= LEAVE CPU-EMU ===============
Total cpuemu time          1022566 us (incl.trace)
Total codgen time           100345 us
Total linker time            66367 us
Total exec   time           394018 us (incl.faults)
Total insert time            61632 us
Total search time            33506 us
Total clean  time            43737 us
Max tree nodes                2714
Max node size                  518
Max tree depth                  14
Nodes parsed                137894
Find misses                 222743
Nodes executed             1064303
Find hits                   199967 (18%)
Find last hits              864336 (81%)
Page faults                   5144
Signals received               148
Tree cleanups                   11

[Index of Archives]     [Linux Console]     [Linux Audio]     [Linux for Hams]     [Kernel Newbies]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite Camping]     [Yosemite Hiking]     [MIPS Linux]     [ARM Linux]     [Linux RAID]     [Samba]     [Linux Media]     [Fedora Users]

  Powered by Linux